快速安装hiphop-php的捷径

不得不说,现在安装hiphop-php实在是太麻烦了,如果有rpm包一次搞定那该多好?就说周边那些零散的依赖库,也有不少安装比较繁琐的硬骨头。

Centos用户的好消息

Update: 在centos 64位机上完全通过rpm安装hiphop-php的步骤也已经提供了。

在邮件组上看到有人提供了centos下安装hiphop相关的rpm列表,把这些rpm装好,再按照wiki上专心编译hiphop即可。也许再过一阵,就会有人直接提供hiphop的rpm包,那就彻底方便了。

rpm列表

    • libicu42-4.2.1-1.x86_64.rpm
    • libicu-devel-4.2.1-1.x86_64.rpm
    • icu-debuginfo-4.2.1-1.x86_64.rpm
    • icu-4.2.1-1.x86_64.rpm
    • libcurl4-devel-7.20.0-1.x86_64.rpm
    • libcurl4-7.20.0-1.x86_64.rpm
    • curl-debuginfo-7.20.0-1.x86_64.rpm
    • curl-7.20.0-1.x86_64.rpm
    • libevent-1.4.13-1.x86_64.rpm
    • boost-devel-1_37_0-1.x86_64.rpm
    • boost-debuginfo-1_37_0-1.x86_64.rpm
    • boost-1_37_0-1.x86_64.rpm
    • cmake-2.6.4-7.el5.x86_64.rpm

Ubuntu 9.10用户的安装指南

Building and Installing on Ubuntu 9.10

看起来还是ubuntu用户最清爽。

注:如果使用了32bit的ubuntu,请使用patch过的hiphop-php进行编译。

Fedora用户的编译步骤

Building HipHop PHP for Fedora 12 on 64 bit and 32 bit Systems

BTW: 目前hiphop-php仅支持64位操作系统。

9 Replies to “快速安装hiphop-php的捷径”

  1. 补充一个:http://www.ioncannon.net/programming/918/building-hiphop-php-for-fedora-12-on-64-bit-and-32-bit-systems/

  2. HipHop currently only supports 64-bit machines ….无语了….最后一部了 Ubuntu =.=

  3. 装了个64位的Centos5.4虚拟机,根据官方的安装方法,根本没那么容易装上,谈啥easy?????
    rpm -Uvh *.rpm 有很多系统默认的库会有依赖关系,难道装Centos的时候要勾掉开发库么?

    我为啥总是装不上呢/郁闷

  4. 安装的确不是太容易,我至少反复编译了七八次。

    你下载了rpm应该会方便点,建议配合yum一起使用,比如:

    yum localinstall xxx.rpm

    这样应该可以解决rpm的依赖关系,你可以试试。

Leave a Reply

Your email address will not be published.